1 . Apa pengertian, fungsi, Contoh, Dari OSI dan TCP/IP ?
Jawab :
Pengertian OSI
OSI merupakan kepanjangan dari Open System Interconnection Di tahun 1984 ISO (Internasional Standarizaation organization) mengeluarkan solusi untuk memberikan standarisasi kompabilitas jaringan-jaringan sehingga tidak membatasi komunikasi antar produk maupun teknologi dari vendor yang berbeda. Dan faktanya OSI merupakan referensi yang telah digunakan mereka dan disederhanakan / dipersempit menjadi TCP/IP model yang akan kita bicarakan lebih lanjutb[edit] Layer dalam OSI Model.
Brikut ini adalah gambaran OSI Layer :
(gambar : roseindia.net)
7. Application, layer yang mendefinisikan pelayanan komunikasi jaringan dalam bentuk aplikasi seperti : Telnet, FTP, HTTP, SMTP, SNMP, SSH
6. Presentation, layer yang mendefinisikan format data seperti ASCII, HTML, JPG dan lainnya yang dikirimkan ke jaringan yang dapat dimanipulasi sehingga bisa di mengerti oleh penerima / kita contohnya anda menerima email tapi tidak bisa tertampil secara sempurna karena ada format yang tidak dikenali. Hal ini merupakan kegagalan dari layer presentasi
5. Session, layer yang mendefinisikan bagaimana memulai mengontrol dan menghentikan sebuah conversation/komunikasi antar mesin, contohnya kalo kita ambil uang di mesin ATM dari memasukan pin sampai dengan mengambil uang yang sebelumnya mesin berkomunikasi dengan server dahulu tentang saldo rekening anda dan jumlah yang anda minta. Dalam Session kita bisa menjumpai SQL, NFS, RPC dan lain-lainnya
4.Transport, layer yang mendefinisikan managemen dari virtual circuit antar host dalam jaringan yang mengandung rangkain protocol dan permasalahan transprotasi data. Dilayer ini mengatur arus koneksi dan pengendalian error dalam proses pengiriman paket data seperti TCP, UDP dan SPX
3. Network, layer yang mendefinisikan akhir pengiriman paket data dimana computer mengidentifikasi logical address sepert IP Adreses bagaimana menuruskan / routing (oleh router) untuk siapa pengiriman paket data.Layer ini juga mendefinisikan fragmentasi dari sebuah paket dengan ukuran unit yang lebih kecil. Router adalah contoh yang tepat dari definisi layer ini.
2. Data Link, layer ini lebih menspesifikan pada bagaimana paket data didistribusikan / ditransfer data melalui media particular, atau lebih yang kita kenal seperti Ethernet, hub dan switches
1. Physical, Layer terendah ini mendefinisikan media fisik dari transmisi paket data dimana protocol digunakan seperti Ethernet pinout, Kabel UTP (RJ45, RJ48 dsb) kita bisa perkirakan layer ini tentang kabel dan konektornya.
[edit] Contoh praktis OSI Model
contoh :
Layer 7, Anda memakai Microsof Outlook yang mempunyay fungsi SMTP dan POP3
Layer 6, anda mengirim email dengan format ASCII atau HTML
Layer 5, anda menggunakan email anda harus menginstal OS dahulu untuk membuka sesi komunikas jaringan.
Layer 4, OS membuka SMTP dengan sebuah TCP socket kemudian protocol terbuka untuk menerima data dari server email
Layer 3, computer mencari IP addres dari SMTP Server dengan melihat routing table yang diberikan OS Router jika tidak ditemukan akan memberikan pesan.
Layer 2, Paket Data dari IP addres di kirimkan oleh Ethernet
Layer 1, mengubah paket data menjadi signal elektrik yang ditransformasilkan pada kabel UTP Cat5.
2. Apa perbedaan, Ciri-ciri, Dati TCP dan UDP?
Jawab :
a). TCP (Transmission Control Protocol) adalah protocol yang connection-oriented, yang berarti komunikasi yang melewatinya membutuhkan handshaking untuk mengatur koneksi end-to-end. Koneksi dapat dibuat dari client ke server, dan kemudian banyak data dapat dikirimkan melalui konesi itu.
TCP memiliki ciri-ciri yaitu sebagai berikut:
- Terpercaya:
TCP mengatur pesan acknoweledegment, retransmission, dan timeout. Banyak usaha untuk mengirimkan pesan yang dibuat dengan terpercaya. Jika hilang ditengah jalan, server akan meminta kembali bagian yang hilang. Di TCP, tidak ada data yang hilang atau dalam beberapa kasus timeouts, koneksi didrop. - Terurut
Jika dua pesan dikirimkan sepanjang koneksi, satu demi satu, pesan yang pertama akan mencapai aplikasi penerima pertama. Ketika paket data tiba di urutan yang berbeda, layer TCP menahan data selanjutnya sampai data yang baru saja datang dapat di urutkan kembali dan dikirimkan ke aplikasi. - Heavyweight
TCP meminta tiga paket hanya untuk mensetup socket, sebelum beberapa data aktual dapat dikirimkan. Ini mengatur koneksi, reliability, dan congestion control. Ini adalah protocol transport yang besar yang didesain di atas IP. - Streaming
Data dibaca sebagai “stream”, dengan tidak membedakan dimana satu paket berakhir dan yang lin dimulai. Paket mungkin dipisah atau digabungkan ke dalam data streams yang lebih besar atau lebih kecil secara sewenang-wenang.
Ciri-ciri UDP adalah:
- Tidak terpercaya:
- Tidak terurut:
- Lightweight
Tidak ada pemesanan pesan, tidak ada pelacakan koneksi, dll. Layer transport yang kecil yang didesain di atas IP.- Datagrams
Paket yang dikirimkan secara individu dan dijamin akan utuh jika sampai. Paket-paket memiliki batas-batas yang pasti, dan tidak dipisan dan dibagi ke dalam data stream yang mungkin ada.
- Datagrams
MAKALAH IP ADDRESSING
- A. Pengertian IP Addressing
Perancang awal dari TCP/IP menetapkan sebuah alamat IP sebagai nomor 32-bit, dan sistem ini, yang kini bernama Internet Protocol Version 4 (IPv4), masih digunakan hari ini. Namun, karena pertumbuhan yang besar dari Internet dan penipisan yang terjadi pada alamat IP, dikembangkan sistem baru (IPv6), menggunakan 128 bit untuk alamat, dikembangkan pada tahun 1995 dan terakhir oleh standar RFC 2460 pada tahun 1998.
Internet Protocol juga memiliki tugas routing paket data antara jaringan, alamat IP dan menentukan lokasi dari node sumber dan node tujuan dalam topologi dari sistem routing. Untuk tujuan ini, beberapa bit pada alamat IP yang digunakan untuk menunjuk sebuah subnetwork. Jumlah bit ini ditunjukkan dalam notasi CIDR, yang ditambahkan ke alamat IP, misalnya, 208.77.188.166/24.
Dengan pengembangan jaringan pribadi / private network, alamat IPv4 menjadi kekurangan, sekelompok alamat IP private dikhususkan oleh RFC 1918. Alamat IP private ini dapat digunakan oleh siapa saja di jaringan pribadi / private network. Mereka sering digunakan dengan Network Address Translation (NAT) untuk menyambung ke Internet umum global.
Internet Assigned Numbers Authority (IANA) yang mengelola alokasi alamat IP global. IANA bekerja bekerja sama dengan lima Regional Internet Registry (RIR) mengalokasikan blok alamat IP lokal ke Internet Registries (penyedia layanan Internet) dan lembaga lainnya.
Sistem pengalamatan IP ini terbagi menjadi dua, yakni:
- IP versi 4 (IPv4)
- IP versi 6 (IPv6)
Informasi ini bisa diketahui dengan mengkombinasikan IP address dengan 32-bit angka subnet mask. IP address memiliki beberapa kelas berdasarkan kapasitasnya, yaitu Class A dengan kapasitas lebih dari 16 juta komputer, Class B dengan kapasitas lebih dari 65 ribu komputer, dan Class C dengan kapasitas 254 komputer.
- B. Alamat IP versi 4
- Alamat Unicast, merupakan alamat IPv4 yang ditentukan untuk sebuah antarmuka jaringan yang dihubungkan ke sebuah internetwork IP. Alamat Unicast digunakan dalam komunikasi point-to-point atau one-to-one.
- Alamat Broadcast, merupakan alamat IPv4 yang didesain agar diproses oleh setiap node IP dalam segmen jaringan yang sama. Alamat broadcast digunakan dalam komunikasi one-to-everyone.
- Alamat Multicast, merupakan alamat IPv4 yang didesain agar diproses oleh satu atau beberapa node dalam segmen jaringan yang sama atau berbeda. Alamat multicast digunakan dalam komunikasi one-to-many.
Alamat IP versi 4 umumnya diekspresikan dalam notasi desimal bertitik (dotted-decimal notation), yang dibagi ke dalam empat buah oktet berukuran 8-bit. Dalam beberapa buku referensi, format bentuknya adalah w.x.y.z. Karena setiap oktet berukuran 8-bit, maka nilainya berkisar antara 0 hingga 255 (meskipun begitu, terdapat beberapa pengecualian nilai).
Alamat IP yang dimiliki oleh sebuah host dapat dibagi dengan menggunakan subnet mask jaringan ke dalam dua buah bagian, yakni:
- Network Identifier/NetID atau Network Address (alamat jaringan) yang digunakan khusus untuk mengidentifikasikan alamat jaringan di mana host berada. Template:BrSemua sistem di dalam sebuah jaringan fisik yang sama harus memiliki alamat network identifier yang sama. Network identifier juga harus bersifat unik dalam sebuah internetwork. Alamat network identifier tidak boleh bernilai 0 atau 255.
- Host Identifier/HostID atau Host address (alamat host) yang digunakan khusus untuk mengidentifikasikan alamat host di dalam jaringan. Nilai host identifier tidak boleh bernilai 0 atau 255 dan harus bersifat unik di dalam network identifier di mana ia berada.
C. Alamat Unicast IP versi 4
Dalam RFC 791, alamat Unicast IP versi 4 dibagi ke dalam beberapa kelas, dilihat dari oktet pertamanya, seperti terlihat pada tabel. Sebenarnya yang menjadi pembeda kelas IP versi 4 adalah pola biner yang terdapat dalam oktet pertama (utamanya adalah bit-bit awal/high-order bit), tapi untuk lebih mudah mengingatnya, akan lebih cepat diingat dengan menggunakan representasi desimal.| Kelas Alamat IP | Oktet pertama Template:Br(desimal) | Oktet pertama Template:Br(biner) | Digunakan oleh |
| Kelas A | 1–126 | 0xxx xxxx | Alamat unicast untuk jaringan skala besar |
| Kelas B | 128–191 | 1xxx xxxx | Alamat unicast untuk jaringan skala menengah hingga skala besar |
| Kelas C | 192–223 | 110x xxxx | Alamat unicast untuk jaringan skala kecil |
| Kelas D | 224–239 | 1110 xxxx | Alamat multicast (bukan alamat unicast) |
| Kelas E | 240–255 | 1111 xxxx | Direservasikan;umumnya digunakan sebagai alamat percobaan (eksperimen); (bukan alamat unicast) |